VLANs  Εργαστήριο

Σχεδιάγραμμα Άσκησης

 

Σε αυτό το Εργαστήριο  υπάρχουν 3  switches cisco 2950 που θα χρησιμοποιήσουμε . Επίσης θα χρειαστούμε έναν Δρομολογητή  της Εταιρείας Cisco μοντέλο 2621  για το ISL routing .

Κατά τη διάρκεια της εργαστηριακής άσκησης Θα δημιουργήσουμε 3 VLAN (Virtual Lan) σε κάθε ένα από τα 2950A, 2950B, και  2950C switch  και στο τέλος θα ικανοποιήσουμε τη συνθήκη σύνδεσης όλων  με τη τεχνική Intervlan Routing στο Δρομολογητή μας  .

 

1.   Αρχίζουμε τις  Βασικές ρυθμίσεις  του Δρομολογητή μας

 

Router>enable

Router#config t

Router(config)#hostname 2600A

2600A(config)#enable secret todd

2600A(config)#line console 0

2600A(config-line)# password todd

2600A(config-line)#login

2600A(config-line)#line aux 0

2600A(config-line)#password todd

2600A(config-line)#login

2600A(config-line)#line vty 0 4

2600A(config-line)#password todd

2600A(config-line)#login

2600A(config-line)#interface fastethernet 0/0

2600A(config-if)#ip address 192.168.100.1 255.255.255.0

2600A(config-if)#description connection to LAN 100

2600A(config-if)#no shutdown

2600A(config-if)#exit

2600A(config)#banner motd #

This is the 2600A router

#

2600A(config)#exit

2600A#copy run start

2600A#


 

2.   Συνδεόμαστε με το 2950A switch και ρυθμίζουμε  hostname, passwords, interface descriptions, IP  address, subnet mask και  default-gateway . Η  IP address του switch θα είναι  192.168.100.2 /24, με   default gateway of 192.168.100.1. Όταν τελειώσετε τις ρυθμίσεις πιστοποιήστε στο  default gateway για να ελέγξετε τη σωστή λειτουργία .

 

Switch>enable

Switch#config t

Switch(config)#hostname 2950A

2950A(config)#enable password todd

2950A(config)#enable secret routersim

2905A(config)#line console 0

2950A(config-line)#password console

2950A(config-line)#login

2950A(config-line)#line vty 0 15

2950A(config-line)#password todd

2950A(config-line)#login

2950A(config-line)#exit

2950A(config)#ip default-gateway 192.168.100.1

2950A(config)#interface VLAN 1

2950A(config-if)#ip address 192.168.100.2 255.255.255.0

2950A(config-if)#interface fastethernet 0/10

2950A(config-if)#description Trunk Link to 2600A

2950A(config-if)#switchport mode trunk

2950A(config-if)#speed 100

2950A(config-if)#duplex full

2950A(config-if)#interface fastethernet 0/11

2950A(config-if)#description Link to 2950B

2950A(config-if)#switchport mode trunk

2950A(config-if)#speed 100

2950A(config-if)#duplex full

2950A(config-if)#interface fastethernet 0/12

2950A(config-if)#description Trunk Link to 2950C

2950A(config-if)#switchport mode trunk

2950A(config-if)#speed 100

2950A(config-if)#duplex full

2950A(config-if)#exit

2950A(config)#exit

2950A#ping 192.168.100.1

 

3.   Δημιουργήστε ένα  VTP domain με όνομα routersim και αφήστε το  switch ως  VTPserver.

 

2950A#config t

2950A(config)#vtp domain routersim

 

4.  Συνδεθείτε στο  2950B switch και ρυθμίστε και εδώ  hostname, passwords, interface descriptions, IP address, subnet mask and default-gateway . Η  IP address του switch θα είναι  192.168.100.3 /24, με   default gateway of 192.168.100.1. Όταν τελειώσετε τις ρυθμίσεις πιστοποιήστε στο  default gateway για να ελέγξετε τη σωστή λειτουργία .

 

 

Switch>enable

Switch#config t

Switch(config)#hostname 2950B

2950B(config)#enable password todd

2950B(config)#enable secret routersim

2950B(config)#line console 0

2950B(config-line)#password console

2950B(config-line)#login

2950B(config-line)#line vty 0 15

2950B(config-line)#password todd

2950B(config-line)#login

2950B(config-line)#exit

2950B(config)#ip default-gateway 192.168.100.1

2950B(config)#interface vlan1

2950B(config-if)#ip address 192.168.100.3 255.255.255.0

2950B(config-if)#interface fastethernet 0/11

2950B(config-if)#description Trunk Link to 2950A

2950B(config-if)#switchport mode trunk

2950B(config-if)#speed 100

2950B(config-if)#duplex full

2950B(config-if)#interface fastethernet 0/12

2950B(config-if)#description Trunk Link to 2950C

 2950B(config-if)#switchport mode trunk

2950B(config-if)#speed 100

2950B(config-if)#duplex full

2950B(config-if)#exit

2950B(config)#exit

2950B#ping 192.168.100.1

 

5.   Ρυθμίστε το 2950B switch ως μέλος του VTP domain με όνομα  routersim και σε κατάσταση VTP client έτσι ώστε να αντλεί όλες τις πληροφορίες που θα χρειάζεται για τα VLANS από το SERVER (2950 A)

 

2950B#config t

2950B(config)#vtp domain routersim

2950B(config)#vtp mode client

 

6.   Συνδεθείτε στο  2950 C switch και ρυθμίστε και εδώ  hostname, passwords, interface descriptions, IP address, subnet mask and default-gateway . Η  IP address του switch θα είναι  192.168.100.4 /24, με   default gateway of 192.168.100.1. Όταν τελειώσετε τις ρυθμίσεις πιστοποιήστε στο  default gateway για να ελέγξετε τη σωστή λειτουργία .

 

Switch>enable

Switch#config t

Switch(config)#hostname 2950C

2950C(config)#enable password todd

2950C(config)#enable secret routersim

2950C(config)#line console 0

2950C(config-line)#password console

2950C(config-line)#login

2950C(config-line)#line vty 0 15

2950C(config-line)#password todd

2950C(config-line)#login

2950C(config-line)#exit

2950C(config)#ip default-gateway 192.168.100.1

2950C(config)#interface vlan1

2950C(config-if)#ip address 192.168.100.4 255.255.255.0

2950C(config-if)#interface fastethernet 0/11

2950C(config-if)#description Trunk Link to 2950B

2950C(config-if)#switchport mode trunk

2950C(config-if)#speed 100

2950C(config-if)#duplex full

2950C(config-if)#interface fastethernet 0/12

2950C(config-if)#description Trunk Link to 2950A

  2950C(config-if)#switchport mode trunk

2950C(config-if)#speed 100

   2950C(config-if)#duplex full

   2950C(config-if)#exit

   2950C(config)#exit

2950C#ping 192.168.100.1

 

7.   Ρυθμίστε το 2950C switch ως μέλος του VTP domain με όνομα  routersim και σε κατάσταση VTP client έτσι ώστε να αντλεί όλες τις πληροφορίες που θα χρειάζεται για τα VLANS από το SERVER (2950 A)

 

   2950C#config t

   2950C(config)#vtp domain routersim

   2950C(config)#vtp mode client

 

8.       Δημιουργήστε 3 VLANs  στο 2950A (vtp-server mode)  switch  με τα ονόματα

 Sales, Marketing, Finance.

   2950A#vlan database

   2950A(vlan)#vlan 2 name Sales

   2950A(vlan)#vlan 3 name Marketing

   2950A(vlan)#vlan 4 name Finance

το Vlan 1 είναι ρυθμισμένο στο switch από κατασκευής  (by default) οπότε εμείς μπορούμε να εισάγουμε Vlans από το 2 και μετά. Το Vlan 1 δεν μπορεί να τροποποιηθεί.   

 

9.   Συνδεθείτε στο  2950B switch και πληκτολόγησε την εντολή show VLAN

      2950B#show vlan

 

Πρέπει να Βλέπετε τα 4 Vlan που δημιουργηθήκανε από το 2950 Α  VTP-SERVER

 

10. Συνδεθείτε στο  2950C switch και πληκτολόγησε την εντολή show VLAN

 

2950C#show vlan

 

Πρέπει να Βλέπετε τα και εδώ τα 4 Vlan που δημιουργηθήκανε από το 2950 Α 

 

 

11. Συνδεθείτε με το 2950A  και  κάντε τη θύρα Fast Ethernet 0/1 να ανήκει στο Vlan  2 και τοποθετείστε στο Host Α  τα ακόλουθα TCP-IP settings

      IP ADDRESS                          192.168.101.2

      SUBNET   MASK                    255.255.255.0

      DEFAULT GATEWAY            192.168.101.1

 

 

2950A#config t

2950A(config)#interface fastethernet 0/1

2950A(config-if)#switchport access vlan 2

2950A(config-if)#switchport mode access

 

Με την επόμενη εντολή τη διαφορετικό βλέπετε στις πόρτες του switch όσο αναφορά τα ports per vlan ?????

2950A#show vlan

 

 

Συνδεθείτε με το 2950B  και  κάντε τη θύρα Fast Ethernet 0/1 να ανήκει στο Vlan  2 και τοποθετείστε στο Host D τα ακόλουθα TCP-IP settings

 

      IP ADDRESS                          192.168.101.3

      SUBNET   MASK                    255.255.255.0

      DEFAULT GATEWAY            192.168.101.1

 

 

 

2950B#config t

2950B(config)#interface fastethernet 0/1

2950B(config-if)#switchport access vlan 2

2950B(config-if)#switchport mode access

 

Συνδεθείτε με το 2950C  και  κάντε τη θύρα Fast Ethernet 0/1 να ανήκει στο Vlan  2 και τοποθετείστε στο Host G τα ακόλουθα TCP-IP settings

 

      IP ADDRESS                          192.168.101.4

      SUBNET   MASK                    255.255.255.0

      DEFAULT GATEWAY            192.168.101.1

 

 

   2950C#config t

   2950C(config)#interface fastethernet 0/1

   2950C(config-if)#switchport access vlan 2

2950C(config-if)#switchport mode access

 

12.  Συνδεθείτε με το 2950A  και  κάντε τη θύρα Fast Ethernet 0/2 να ανήκει στο Vlan  3 και τοποθετείστε στο Host B τα ακόλουθα TCP-IP settings

      IP ADDRESS                          192.168.102.2

      SUBNET   MASK                    255.255.255.0

      DEFAULT GATEWAY            192.168.102.1

 

 

 

   2950A#config t

   2950A(config)#interface fastethernet 0/2

   2950A(config-if)#switchport access vlan 3

2950A(config-if)#switchport mode access

 

Συνδεθείτε με το 2950B  και  κάντε τη θύρα Fast Ethernet 0/2 να ανήκει στο Vlan  3 και    τοποθετείστε στο Host E τα ακόλουθα TCP-IP settings 

  

       IP ADDRESS                         192.168.102.3

      SUBNET   MASK                    255.255.255.0

      DEFAULT GATEWAY            192.168.102.1

 

 

 

   2950B#config t

   2950B(config)#interface fastethernet 0/2

   2950B(config-if)#switchport access vlan 3

2950B(config-if)#switchport mode access

 

Συνδεθείτε με το 2950C  και  κάντε τη θύρα Fast Ethernet 0/2 να ανήκει στο Vlan  3 και    τοποθετείστε στο Host H τα ακόλουθα TCP-IP settings 

  

        IP ADDRESS                         192.168.102.4

       SUBNET   MASK                    255.255.255.0

       DEFAULT GATEWAY            192.168.102.1

 

   2950C#config t

   2950C(config)#interface fastethernet 0/2

   2950C(config-if)#switchport access vlan 3

   2950C(config-if)#switchport mode access

 

 

13.   Συνδεθείτε με το 2950A  και  κάντε τη θύρα Fast Ethernet 0/3 να ανήκει στο Vlan  4 και    τοποθετείστε στο Host C τα ακόλουθα TCP-IP settings 

 

        IP ADDRESS                         192.168.103.2

       SUBNET   MASK                    255.255.255.0

       DEFAULT GATEWAY            192.168.103.1

 

 

   2950A#config t

   2950A(config)#interface fastethernet 0/3

   2950A(config-if)#switchport access vlan 4

2950A(config-if)#switchport mode access

   

Συνδεθείτε με το 2950B  και  κάντε τη θύρα Fast Ethernet 0/3 να ανήκει στο Vlan  4 και    τοποθετείστε στο Host F τα ακόλουθα TCP-IP settings 

 

       IP ADDRESS                         192.168.103.3

       SUBNET   MASK                    255.255.255.0

       DEFAULT GATEWAY            192.168.103.1

 

   2950B#config t

   2950B(config)#interface fastethernet 0/3

   2950B(config-if)#switchport access vlan 4

2950B(config-if)#switchport mode access

 

Συνδεθείτε με το 2950C  και  κάντε τη θύρα Fast Ethernet 0/3 να ανήκει στο Vlan  4 και    τοποθετείστε στο Host I τα ακόλουθα TCP-IP settings 

 

       IP ADDRESS                         192.168.103.4

       SUBNET   MASK                    255.255.255.0

       DEFAULT GATEWAY            192.168.103.1

 

   2950C#config t

   2950C(config)#interface fastethernet 0/3

   2950C(config-if)#switchport access vlan 4

   2950C(config-if)#switchport mode access

 

15. Ενεργοποίηση Intervlan Routing  στο Δρομολογητή μας

 

 

 Δημιουργούμε τόσα subinterface στη Fastethernet θύρα του Δρομολογητή μα  που διασυνδέεται με το 2950 Α Server-switch όσα και τα vlan που δημιουργήσαμε στα switch  του δικτύου μας .

 

Διαγράψτε από τη fastethernet τη διεύθυνση που είχατε δώσει και ακολουθείστε τη παρακάτω δομή για το δρομολογητή σας

 

 

interface FastEthernet0/0

  description connection to LAN 100

  no ip address

  no ip directed-broadcast

!

interface FastEthernet0/0.1         subinterface  για την ενεργοποίηση του vlan  1

   encapsulation dot1Q 1       ενθυλάκωση σε πρωτόκολλο  dot1Q για το vlan 1

  ip address 192.168.100.1 255.255.255.0 αποτελεί το Gateway για το Vlan 1

!

interface FastEthernet0/0.2       subinterface  για την ενεργοποίηση του vlan  2

  encapsulation dot1Q 2     ενθυλάκωση σε πρωτόκολλο  dot1Q για το vlan 2

  ip address 192.168.101.1 255.255.255.0 αποτελεί το Gateway για το Vlan 2

!

interface FastEthernet0/0.3    subinterface  για την ενεργοποίηση του vlan  3

  encapsulation dot1Q 3    ενθυλάκωση σε πρωτόκολλο  dot1Q για το vlan 3

  ip address 192.168.102.1 255.255.255.0 αποτελεί το Gateway για το Vlan 3

!

interface FastEthernet0/0.4     subinterface  για την ενεργοποίηση του vlan  4

  encapsulation dot1Q 4       ενθυλάκωση σε πρωτόκολλο  dot1Q για το vlan 4

  ip address 192.168.103.1 255.255.255.0   αποτελεί το Gateway για το Vlan 4

!

 

 

 

16.

 router eigrp 100

 network 192.168.100.0                  Ενεργοποίηση Intervlan Routing  στο

 network 192.168.101.0                 Δρομολογητή μας

 network 192.168.102.0

 network 192.168.103.0

!

 

 

17.  Πιστοποιήστε τη σωστή λειτουργία του Δικτύου από άκρη σε άκρη με τη βοήθεια της εντολής ping για κάθε προορισμό